© Intesis Software S.L.U. All Rights Reserved.

Information in this document is subject to change without notice. The software described in this document is furnished under a license agreement or nondisclosure agreement. The software may be used only in accordance with the terms of those agreements. No part of this publication may be reproduced, stored in a retrieval system or transmitted in any form or any means electronic or mechanical, including photocopying and recording for any purpose other than the purchaser’s personal use without the written permission of Intesis Software S.L.U.

Intesis Software S.L.U.
Milà i Fontanals, 1 bis - 1º
08700 Igualada
Spain

TRADEMARKS
All trademarks and tradenames used in this document are acknowledged to be the copyright of their respective holders.
Gateway for the integration of KNX / EIB systems into ASCII EIA-232 or TCP/IP enabled control systems.

One single model is available for this gateway, with the following order code:

**IBOX-ASCII-KNX**
Model supporting up to 4000 internal datapoints.
INDEX

1. Description ........................................................................................................................................ 5
   1.1 Introduction ................................................................................................................................ 5
   1.2 Functionality ................................................................................................................................. 6
   1.3 Capacity of IntesisBox ................................................................................................................... 7
2. ASCII interface of IntesisBox .............................................................................................................. 8
   2.1 Description ................................................................................................................................... 8
   2.2 Points definition ............................................................................................................................ 9
3. KNX TP-1 (EIB) interface of IntesisBox ............................................................................................ 10
   3.1 Description ..................................................................................................................................... 10
   3.2 Points definition ............................................................................................................................ 11
4. LinkBoxEIB, Configuration & monitoring tool for IntesisBox KNX series ........................................ 12
   4.1 Introduction .................................................................................................................................. 12
   4.2 Project definition ........................................................................................................................... 12
   4.3 Connection configuration .............................................................................................................. 18
   4.4 Signals configuration ...................................................................................................................... 20
      4.4.1 Remember .............................................................................................................................. 24
      4.4.2 Restrictions ............................................................................................................................. 24
   4.5 Saving the configuration and Sending it to IntesisBox ................................................................. 25
   4.6 Signals viewer .............................................................................................................................. 26
   4.7 System commands ......................................................................................................................... 27
   4.8 Files .............................................................................................................................................. 28
5. Integration of IntesisBox® in ETS .......................................................................................................... 29
6. Setup process and troubleshooting ................................................................................................... 30
   6.1 Pre-requisites .................................................................................................................................. 30
   6.2 Setup procedure ............................................................................................................................ 30
7. Connections ....................................................................................................................................... 33
8. Mechanical & electrical characteristics ............................................................................................ 35
9. Dimensions ........................................................................................................................................ 36
1. Description

1.1 Introduction

This document describes the integration of KNX/EIB systems with ASCII enabled control systems¹ using the IntesisBox ASCII Server - KNX gateway.

This document assumes that the user is familiar with KNX/EIB technology and technical terms.

From now on, and with the aim of easy the read of this document, just the word "IntesisBox" will be used instead of the full gateway model description "IntesisBox ASCII Server - KNX".

The aim of this integration is to make accessible signals and resources of any KNX/EIB system or device from any system capable of "talking" simple ASCII protocol (for example AMX, CRESTRON or Extron controllers).

For this, the gateway acts as a KNX device in its KNX interface, reading/writing points of other KNX devices of the installation, and offering this point's values of KNX device through its ASCII interface using simple ASCII messages.

---

¹ The term "ASCII enabled control systems" will be used along this document to refer to supervision/control/automation systems allowing to be programmed to read and write simple text messages through EIA-232 serial port or Ethernet TCP/IP port.
1.2 Functionality

The integration operation is as follow:

From the KNX system point of view, after the start up process, the gateway reads the points configured to be read at the start, and remains listening for changes of value of group addresses associated to internal datapoints. Any of these changes, when detected, are immediately updated in memory and become available to be read by the ASCII system in any moment.

From the ASCII system point of view, after the start up process of the gateway, the gateway waits for any query (ASCII messages requesting readings of points or ASCII messages requesting writings of points), and acts according to the message received. See ASCII interface section for details about this ASCII messages.

Also, whenever an internal datapoint changes of value (due to a change in the KNX group address associated) the gateway will send an ASCII message informing about new value for the point, but only if the point is configured to send this type of spontaneous messages.
### 1.3 Capacity of IntesisBox

<table>
<thead>
<tr>
<th>Element</th>
<th>Max.*</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type of KNX devices</td>
<td>Those supporting S-Mode communication on KNX TP-1 (EIB bus).</td>
<td></td>
</tr>
<tr>
<td>Number of internal datapoints</td>
<td>4000</td>
<td>Maximum number of datapoints that can be defined in IntesisBox. Each datapoint can be associated to a different KNX group address.</td>
</tr>
</tbody>
</table>

*These maximum values can be extended on demand.

One single model is available for *IntesisBox ASCII Server – KNX* gateway, and it support up to 4000 internal datapoints.

*Ref.: IBOX-ASCII-KNX*
2. ASCII interface of IntesisBox

This section describes the ASCII interface of the gateway, its configuration and functionality.

2.1 Description

The gateway can be connected to any ASCII enabled device using its EIA232 interface (DB9 connector DTE), and offers through this interface the possibility of supervision and control of its internal datapoints using simple ASCII messages.

On receiving messages corresponding to write commands in its ASCII interface, the gateway sends the corresponding write telegram to the associated KNX group.

When a new value for a point is received from KNX, the corresponding ASCII message indicating the new value will be sent through the ASCII interface, but only if the point is configured for sending this "spontaneous messages", if it is not configured to do so, then the new value will be available to be polled in any moment from the ASCII enabled device connected to this ASCII interface. This behaviour of sending or not through the ASCII interface the new values received from KNX is configurable individually per point into the gateway.

The communication parameters of this ASCII interface are the following:
Baud rate: configurable (1200 bps ... 57600 bps).
Data bits: 8.
Parity: None.
Stop bits: 1.

The ASCII messages used to read/write points into the gateway through this interface are:

Message to read a point's value:

>Daaaa?\r

Where:
Daaaa is a 4 digits number indicating the point's address inside the gateway (see point addresses details below in this document).
\r means carriage return character (HEX 0D, DEC 13).

Message to write a point's value:

>Daaaa=vv\r

Where:
Daaaa is a 4 digits number indicating the point's address inside the gateway (see point addresses details below in this document).

vv is the desired value for the point (it can be just integer or fractional, decimal point is used to separate integer and fractional parts if the number is fractional).
\r means carriage return character (HEX 0D, DEC 13).

Message informing about a point's value (sent spontaneously by the gateway when receiving a change from KNX or sent by the gateway in response to a previous poll for the point):

\r

>Da\r

Where:

Da is a 4 digits number indicating the point's address inside the gateway (see point addresses details below in this document).

\r means carriage return character (HEX 0D, DEC 13).

Messages to indicate erroneous actions:

\r

>E01\r Is returned when trying to read a point not configured in the gateway.

>E02\r Is returned when trying to write a point not permitted to be written.

2.2 Points definition

Every point defined in the gateway has the following ASCII features associated to it, which can be configured (optionally or mandatory depending on the feature):

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Address *</td>
<td>Datapoint address. Used in the ASCII telegram to read/write the datapoint.</td>
</tr>
<tr>
<td>Spontaneous *</td>
<td>Determines if any change of value for the point received from KNX will generate a spontaneous ASCII message to send through the ASCII interface informing about the new value.</td>
</tr>
<tr>
<td>Active *</td>
<td>If activated means that the signal is active for the gateway, if not activated is like signal not defined. It allows you to deactivate signals without the need of delete them (useful for future use of this signals).</td>
</tr>
</tbody>
</table>

* Configuration for this feature is mandatory.
3. Konnex TP-1 (EIB) interface of IntesisBox

This section describes the KNX part of the gateway's configuration and functionality. This section assumes the user is familiar with KNX technology and technical terms.

3.1 Description

The gateway connects directly to the EIB bus (KNX TP-1) thanks to its internal EIB bus coupling unit, and acts as one more device of the KNX system with the same behaviour and configuration characteristics, except that the KNX configuration of the device is not performed using KNX ETS software but using LinkBoxEIB software, like all the rest of the IntesisBox KNX series gateways.

Internally, the bus coupling circuitry is opto-coupled from the rest of the electronics of the device to prevent damage of all the system in case of electrical pulse or over-voltage coming from the EIB bus.

The gateway manages all the communication with the EIB bus according to its configuration.

On receiving messages from KNX, if they are destined to the EIB groups associated to internal datapoints, the gateway updates its point’s values in memory, ready to be served to ASCII when requested.

When a change in a configured datapoint is received from the ASCII interface, the corresponding telegram will be sent to associated EIB group address of the KNX system (only if the point is configured to do so, this means if the point is configured as “T” - Transmit).

The device continuously checks the status of the KNX TP-1 (EIB) bus, if a bus loss is detected, due to a bus power failure for example, on restoration of the EIB bus the gateway will re-transmit the status of all the groups configured as “T” (transmit) and also will perform the Updates for the groups configured as “U” or “U2”.
3.2 Points definition

Every point defined in the gateway has the following KNX(EIB) features associated to it, which can be configured (optionally or mandatory depending on the feature):

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Signal or datapoint description. Only for information purposes at user level.</td>
</tr>
<tr>
<td>EIS (DataPoint)</td>
<td>KNX data type to encode the signal’s value. It will depend on the KNX type of object associated to it in each case.</td>
</tr>
<tr>
<td>Group</td>
<td>Is the EIB group address associated to the datapoint. It is also the EIB group to which will be applied the reading(R), writing(W), transmit(T) and update(U or U2) features. Is the EIB sending group or main group.</td>
</tr>
<tr>
<td>Listening addresses</td>
<td>These are the EIB group addresses that will also actuate on the datapoint, apart from the main EIB group address mentioned above.</td>
</tr>
<tr>
<td>R</td>
<td>Read. If this flag is active, it means that this EIB group can be read from KNX system.</td>
</tr>
<tr>
<td>W</td>
<td>Write. If this flag is active, it means that this EIB group can be written from KNX system.</td>
</tr>
<tr>
<td>T</td>
<td>Transmit. If this flag is active, it means that when the value of this datapoint changes in the gateway, a message will be sent to the KNX system indicating the new value for this EIB group address.</td>
</tr>
<tr>
<td>U or U2</td>
<td>Update. If flag “U” is active, it means that when the gateway starts up or after an EIB bus reset, a KNX read will be performed (of the main EIB group), then the received value will update the datapoint's value in the gateway's memory as it would happen for a normal write of this EIB group from KNX. If flag “U2” is active, it means that when the gateway starts up or after an EIB bus reset, a KNX read will be performed (of the first EIB group listening address defined), then the received value will update the datapoint's value in the gateway's memory as it would happen for a normal write of this EIB group (the first listening address defined) from KNX.</td>
</tr>
<tr>
<td>Active</td>
<td>If active, it means that the datapoint is active for the gateway, if not active is like datapoint not defined. It allows you to deactivate datapoints without the need of delete them (useful for future use of these datapoints).</td>
</tr>
</tbody>
</table>

* Configuration for this feature is mandatory.

All the mentioned flags (R,W,T,U,U2) related to the KNX part are configurable for every point in the gateway, with some necessary restrictions (see below in this document).
4. **LinkBoxEIB. Configuration & monitoring tool for IntesisBox KNX series**

4.1 **Introduction**

LinkBoxEIB is a Windows compatible software tool developed specifically to monitor and configure IntesisBox KNX series gateways. It is possible to configure all external protocols available for IntesisBox KNX and to maintain different customer’s configurations based on a LinkBoxEIB project for every different installation. Maintaining always on hard disk a copy of the last configuration files for every external protocol and customer, that is to say for every project.

From LinkBoxEIB, as well as configure the integration signals list and connection parameters for every external protocol, it is permitted also to select the serial port to use to connect to IntesisBox and the use of some tools for monitoring and debugging the device. Some of these tools will be explained in this document but only some of them, the rest of available debugging tools and commands will not be explained here because they are for exclusive use under the recommendations of Intesis Software technical support.

LinkBoxEIB allows configuring all IntesisBox KNX series independently of the external system or protocol used. For every external system, LinkBoxEIB has a specific configuration window. Periodically, new free versions of LinkBoxEIB are released incorporating the latest developed integrations for external systems.

4.2 **Project definition**

The first step to do in LinkBoxEIB for a new installation is to create the installation’s project giving a descriptive name to it. When you create a project, a new folder is created with the name of the project containing the configuration files needed depending on the external protocol selected for the project. It is strongly recommended that you create a new project for every installation, if not, overwriting of configuration files of previous installations using the same external protocol may occur, loosing the configuration data for those previous installations. The projects folder is located in AppFolder\ProjectsEIB, where AppFolder is the installation folder of LinkBoxEIB (by default C:\Program Files\Intesis\LinkBoxEIB). Inside the projects folder, a new folder will be created for every project defined in LinkBoxEIB with the files needed for the project.

When you open LinkBoxEIB, the project selection window will appear inviting you to select a project or to create a new one. A demo project for every external protocol supported is provided with the standard installation of LinkBoxEIB.

You can create a brand new project, which will create a blank project (only basic parameters will be already configured), or you can select a demo project based on the external protocol desired and create a new project based on this demo project selected (all the configuration of the demo project will be copied into the new project created).
Project selection window

To create a new project, select a project using the same external protocol you want to use in the new project and push New button. You will be prompted to create a copy of the selected project (useful for similar installations) or create a brand new one.

If you select Yes, you will be prompted to specify a name and a description for the new project that will contain a copy of the configuration of the selected one.

If you select No, you can specify a name, a description and an external protocol to use from the list of available external protocols. This will create a brand new project based in the external protocol specified.
On *Accept*, a new folder will be created inside the projects folder with the name given to the project, this folder will contain the template configuration files if the project is a brand new one, or a copy of the configuration files if it is a copy of a selected one.

A description of the files created for an ASCII protocol based project can be found in section *Files* below in this document.

From all the possibilities of LinkBoxEIB, only changes in configuration for the integration and configuration file generation can be performed while disconnected from IntesisBox (working off-line), allowing you to do these tasks in the office more comfortably. Before any monitoring or downloading action to IntesisBox can be performed, the connection between IntesisBox and the PC running LinkBoxEIB must be established (working on-line). To do so follow these steps:

1. Make sure IntesisBox is powered-up a correctly connected to the KNX system via the EIB bus and to the ASCII system via the EIA-232 connection or TCP/IP connection (consult details for connection and pin assignments in section *Connections* of this document).

2. Connect a free PC serial port to IntesisBox's serial port marked as *PC Console*. (Use the standard serial cable supplied with IntesisBox or make your own cable following the pin assignments specified in section *Connections* in this document).

   If using the Ethernet connection, connect an Ethernet cable between the *Pc Console* port of the IntesisBox and the PC or the corresponding Ethernet interface (Check *Connections* section in this document for more information).

3. If using the *EIA-232* (Serial) port, select in LinkBoxASCII the PC serial port used for the connection to IntesisBox. Use menu Configuration -> Connection.

   If using the *Ethernet* (IP/TCP) port, select in LinkBoxASCII the IP option with the corresponding IP.
1. Check the checkbox **off-line** under the menu bar (it will change automatically to **on-line**) and LinkBoxEIB will ask for INFO about the IntesisBox connected to it via the serial connection, if the connection is ok then IntesisBox will respond with its identification (this can be monitored in the *IntesisBox Communication Console* window, as showed below).

Once connected to the IntesisBox, all the options of LinkBoxEIB are fully operative.

To monitor the communication between IntesisBox and the KNX system, select the menu **View** -> **Bus** -> **EIB**. The *EIB communication Viewer* window will be opened. This window shows in real time all the communication frames between IntesisBox and the KNX system as well as debugging messages referent to the internal protocol (KNX) sent by IntesisBox.
To monitor the communication between IntesisBox and the external system (ASCII in this case), select the menu View -> Bus -> External system. The External protocol communication viewer window will be opened. This window shows in real time all the communication frames between IntesisBox and the ASCII device as well as debugging messages referent to external protocol (ASCII) sent by IntesisBox.
4.3 Connection configuration

To configure the integration connection parameters, and the points list, select menu Configuration -> IntesisBox. The ASCII Configuration window will be opened.

Select the Connection tab to configure the connection parameters.

Two kinds of information are configured using this window, the parameters of the KNX interface, and the parameters of the ASCII interface.

KNX interface configuration parameters:

1. Enter the physical address desired for IntesisBox inside the KNX network.
2. Check this if you want IntesisBox to force the readings in KNX of those points configured with "U" or "U2" flag after a KNX bus reset detection.
3. Delay (in seconds) to wait before perform the readings in KNX of those points configured with "U" or "U2" flag after a KNX bus reset detection (configure it at least to 4 seconds to allow all the devices in the KNX bus to start-up correctly after a bus power failure).
4. Select the firmware version of the gateway, (V.4x.1.x since 24/02/2015).
ASCII interface configuration parameters:

1. Select the type of ASCII port used: ASCII over EIA-232 or ASCII over Ethernet (TCP/IP). (Both ASCII ports cannot be used simultaneously)

2. Enter the ASCII EIA-232 baud rate to use.

3. Enter the ASCII EIA-232 data bits to use.

4. Enter the ASCII EIA-232 parity bit to use.

5. Enter the IP address for the gateway (supplied by the network administrator).

6. Enter the IP NetMask for the gateway (supplied by the network administrator).

7. Enter the Default gateway address (Router address) in case the gateway (IntesisBox) is in a different sub network than the other ASCII TCP/IP devices (supplied by the network administrator). Leave this blank if there is no need of a router address.

8. Enter the ASCII port number to use for ASCII over Ethernet (TCP/IP).

9. Enter the “Time without activity” (in 0..65535 seconds) to send the “Keep Alive” packet, if set to “0” this function is disabled (no packet will be send).

10. Enter the timeout (in 0..2000 milliseconds) to wait for sending consecutive spontaneous ASCII frames.

11. Check this if you want the gateway to respond with >OK\r after receiving a successful write messages.
## Signals configuration

Select the Signals tab to configure the signals list (the IntesisBox’s internal datapoints).

![Signals list](image)

1. **#.** Signal’s number (edit not permitted). Every row in the grid corresponds to a signal (datapoint). Signals (rows in the grid) can be added or deleted selecting the desired row and clicking Add or Delete buttons. Deletion action can be executed for a single row or even for some consecutive rows, all the rows selected will be deleted. This column is used only to enumerate the rows in the grid (signals).

2. **Type.** Indicates the type of datapoint, not modifiable for the moment, reserved for future use.

3. **Add.** Datapoint’s address. To be used by the ASCII messages sent and received through the ASCII interface to refer to the point. For example if the point has address 1, then all the ASCII massages related to this point will contain 0001 in the address field (i.e. >D0001?\r to request the actual value of the point).

4. **R/W.** Indicates if the datapoint is read only, write only or read/write, always from the ASCII system point of view. This value can not be modified directly from this column, the value in this column will be automatically updated depending on the KNX flags selected for the datapoint.

5. **A/D.** Indicates if the datapoint is of type analog or digital. This value can not be modified directly from this column, the value in this column will be automatically updated depending on the KNX EIS selected for the datapoint.

6. **Spontaneous.** Indicates if the gateway will send or not a spontaneous message through the ASCII interface indicating the new value whenever the point’s value changes. Possible values: 0-NoSpon, 1-Spon. Edit using the mouse right-button-click menu available on the column.

7. **Description.** Signal’s description. Used to describe the signal at user level.
8. **EIS.** KNX data type (Data point) to encode the signal’s value. Possible values are: switching (1 bit), dimming (4 bit), float (16 bit), scaling (8 bit), drive control (1 bit), priority (2 bit), float IEEE (32 bit), counter (8 bit), counter (16 bit), counter (32 bit), ASCII char (8 bit). Edit using the mouse right-button-click menu available on the column.

9. **Group.** Main EIB group address for the signal. Format: P/I/S or P/S. Flags **R, W, T, U** explained below will only apply for this main EIB group address, not for listening addresses (if defined). It is the sending group address.

10. **Listening addresses.** EIB group addresses that will be listen by IntesisBox for this signal, that is to say, if IntesisBox receives an EIB telegram with destination one of these listening addresses, then the telegram will be taken into account and the corresponding action will be performed on this signal. Format: P/I/S or P/S, if more than one is entered then they must be separated by comma.

11. **R.** Indicates if this signal is allowed to be read from KNX system. Possible values: “R” or blank. “R” means flag activated.

12. **W.** Indicates if this signal is allowed to be written from KNX system. Possible values: “W” or blank. “W” means flag activated.

13. **T.** Indicates if this signal will generate a telegram sending to the KNX system following a change of the signal’s value, that is to say, any change of value of this signal in ASCII side will be transmitted to the KNX system if this flag is activated. Possible values: “T” or blank. “T” means flag activated.

14. **U.** Indicates if this signal will be updated whenever IntesisBox starts up or after an EIB bus reset. “U” means flag activated for the main EIB group address (a read of the main EIB group address will be performed in the KNX system for the update). “U2” means flag activated for the first listening address defined (a read of the first listening address defined for the point will be performed in the KNX system for the update). Blank means flag not activated. Edit using the mouse right-button-click pop-up menu available on the column.

15. **Active.** Indicates if the signal is active or not for the integration. Possible values: 0-No, 1-Yes. Edit using the mouse right-button-click menu available on the column.

16. **Buttons to move the selected row (or rows) up or down inside the grid.** To move up or down inside the grid a single row or a group of consecutive rows, just select the row or rows using the left button of the mouse and push the desired up or down button. (This can be done also using the key combinations **ALT+arrow up or ALT+arrow down** instead of up or down buttons).
Useful tips for a more quick and comfortable use and configuration of the signals table:

The columns *Spon*, *EIS*, *R*, *W*, *T*, *U* and *Active* can be modified selecting one or just more than one consecutive cells in the same column and using the contextual menu appearing with mouse right button click over the cells selected.

The columns *R*, *W*, *T*, *U* and *Active* can be also modified using mouse-left-button double-click over the desired cell.

In column *Add* you can enter the desired value individually per cell or you can auto enumerate some consecutive cells, for this last follow these steps:

1. Select using the left mouse button (clicking and dragging) the *Add* field of all the rows in the list to which you want to automatically assign addresses (must be consecutive rows).

2. Click right mouse button over the selected fields and select *Auto Enumeration* option from the pop-up menu that will appear.

3. Enter the first value to assign.
4. Enter the increment between consecutive assignments. For example selecting 1 for the first value and an increment of 1, the values generated will be 1, 2, 3, 4, 5... and so on.
4.3.1 Remember

- If "T" is not activated, the changes in the external system (ASCII) will not be transmitted to the KNX.
- If "R" is not activated, the KNX group address could not be read by Read Requests from KNX.
- If "W" is not activated, no write on the group address could be done from KNX, neither on the links (listening addresses).
- If "U" is activated, after IntesisBox start-up or a KNX bus reset, READ Requests will be sent to KNX to update the sending group.
- The groups defined as just links, will take the EIS of the first linked group.
- The data of the groups read from KNX due to read requests between other KNX devices, will be treated as writes on the groups (standard behaviour BCU1).
- Automatic type conversion is performed by IntesisBox, for example if an EIS5 is received by a group of type EIS1, then it is performed the conversion EIS1=(EIS5<>0), or EIS5=EIS9 and EIS9=EIS5, EIS6=EIS5(0..255), etc.
- It is recommended that listening addresses associated to different groups maintain the same EIS in all the groups, if not, non desired conversions can be performed.
- A write from KNX is propagated to the external system through the group address and also through the listening addresses.
- A write from the external system is NOT propagated to KNX through the listening addresses, but DO update the local sending groups that are used as listening addresses.
- If a sending group is used as listening address with other local sending groups, a write from the external system will update the sending group but not the listening addresses.

4.3.2 Restrictions

- It is allowed group numbers in format P/I/S, P/S or directly the group number coded.
- It is not allowed duplicated sending groups (column Group).
- Group 0 is not allowed, it is used for signals without sending group.
- NO signal is allowed with none of R-W-T-U flags activated.
- Empty groups are allowed, but only if they have just W activated and one or more listening addresses.
- Duplicated groups in the same listening address field are not allowed.
- It is not allowed a listening address that is the same as the sending group (circular reference).
- Listening addresses are not allowed if the flag W is not activated. Without W activated, the listening addresses would not work.
- Only those EIS defined are allowed.
4.4 Saving the configuration and Sending it to IntesisBox

When the configuration is finished, click on button Save to save it to the project folder on hard disk. You will be prompted to generate the configuration file to send to IntesisBox, if you select Yes, the binary file containing the configuration for IntesisBox will be generated and saved also into the project folder.

Once the configuration has been saved and the configuration file for IntesisBox has been generated, to send this configuration file to IntesisBox, click on the button Send File. The process of file transmission can be monitored in the IntesisBox Communication Console window. If the file transmission is ok, IntesisBox will reboot automatically with the new configuration loaded.
4.5 Signals viewer

Once IntesisBox is running with the correct configuration, to supervise the status of the configured signals, select menu View -> Signals. The Signals Viewer window will be opened. This window shows all the active IntesisBox’s signals with its main configuration parameters and its real time value in the column Value. After a reset of IntesisBox or after sending a configuration file to the IntesisBox, all the signal’s values will be updated automatically in the signals viewer, in case you connect to the IntesisBox when it is already running, you should press the Update button to get updated values, press just once the button to update all the signal values, from this moment the signal values will be maintained updated until the connection is closed.

![Signals Viewer Window](image)

The signals viewer can be used although only one system is connected to the IntesisBox, KNX or ASCII, and is very useful for supervision and test.

It is possible to force a specific value to any signal for test purposes, to do so just double click on the row and select the desired value and Accept in the Data Test window. If the signal has T activated, its value will be updated and a telegram will be sent to KNX indicating the new value, the same way as if it has been received from ASCII system. If the signal has W activated, the new value entered will be sent to the external system, ASCII in this case, the same way as if it has been received from KNX.

![Test Data Window](image)

This tool is very useful to test any of the systems connected to the IntesisBox, KNX and ASCII without the need to actuate on the real signals.
The signals viewer window has a button to copy to the Windows Clipboard all the contents of the window (in tab separated text format).

### 4.6 System commands

LinkBoxEIB includes an option to send to IntesisBox a set of system commands for debugging and control purposes; this list is available in the commands list as shown in the figure below. To send a command to IntesisBox just select it from the list, or type it with the correct format, and press Enter or click on button Send. IntesisBox will act accordingly with the command received; the process can be monitored in the IntesisBox Communication Console window. The use of some of these commands can be critical for IntesisBox normal operation, having this in mind use only these commands following the recommendations of Intesis Software technical support. A list of the more commonly used commands and the way to use them will be returned by IntesisBox after sending the HELP command.
4.7 Files

LinkBoxEIB saves IntesisBox configuration in the following files inside the project folder:

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PROJECT.INI</td>
<td>.ini file containing general information referent to the project</td>
</tr>
<tr>
<td>ASCII.INI</td>
<td>.ini file containing the information referent to the connection window and other special adjustments</td>
</tr>
<tr>
<td>ASCII.DAT</td>
<td>Text file (tab separated values) with the signals information (signals list). This file can be edited (with Excel for example) to change the configuration quicker and easier. Later on, when selecting Configuration -&gt; IntesisBox in LinkBoxEIB, if the changes have been made respecting the correct format, all the changes in the configuration done from Excel can be seen in the signals list.</td>
</tr>
<tr>
<td>ASCII.LBOX</td>
<td>Binary file created from the information in the files described above. This is the file really uploaded to IntesisBox.</td>
</tr>
</tbody>
</table>

It is strongly recommended to back up the project folder containing these files in external media, once the installation process is finished. This way you will be able to do future configuration changes in case of reinstallation of LinkBoxEIB due, for example, to a failure of the hard disk in the PC where LinkBoxEIB was previously installed.

*The configuration cannot be downloaded from IntesisBox to LinkBoxEIB, only can be uploaded; the upload file ASCII.LBOX does not contain all the integration information, as for example the signals description.*
5. Integration of IntesisBox® in ETS

As explained in previous section the IntesisBox® is configured with the LinkBoxEIB but in some projects it might be needed to integrate the gateway in the ETS project, for example to allow the line couplers have a correct configuration of their filter tables. To do so a Dummy device can be used in ETS to simulate the IntesisBox and associate also to this dummy device all group addresses used in IntesisBox.

In [http://www.intesis.com/down/eib/Dummy_Intesis.zip](http://www.intesis.com/down/eib/Dummy_Intesis.zip) an ETS project containing a Dummy device can be downloaded for this purpose. To use it with your ETS project follow these steps:

1) Import the pr3/pr5 file in ETS and follow the instructions
   - ETS3: menu File → Import.
   - ETS4: Projects → Import projects

2) Open the project named Dummy Intesis.

3) In this Dummy Intesis project, in topology tree, you will find the device “Dummy Intesis”. Select this device (click on it) and copy it (menu Edit → Copy).

4) Open your target project, select the desired line and paste the device there (menu Edit → Paste).

Once that is done the group addresses can be configured. To do so the same addresses configured in the LinkBoxEIB need to be written in the right data type.
6. Setup process and troubleshooting

6.1 Pre-requisites

It is necessary to have the ASCII enabled device operative and ready to be connected to the ASCII interface of IntesisBox. The ASCII massages to use to communicate to the gateway (see format above in this document) should be configured in the ASCII enabled device.

It is necessary to have an EIB bus connection near IntesisBox with all KNX devices willing to integrate connected to this EIB network and correctly configured and commissioned.

Connectors, connection cables and PC for LinkBoxEIB are not supplied by Intesis Software for this standard integration. The items supplied by Intesis Software for this integration are:

- IntesisBox gateway with ASCII protocol and KNX protocol firmware loaded.
- Console cable. Standard DB9F-DB9M cable 1.8 meters long.
- LinkBoxEIB software.
- Product documentation.

6.2 Setup procedure

1. Install LinkBoxEIB on your laptop.

2. Install IntesisBox in the desired installation site. The mounting can be on DIN rail or on a stable not vibrating surface (DIN rail mounting inside a metallic industrial cabinet connected to ground is recommended).

3. Connect the EIA-232 or Ethernet cable coming from the ASCII enabled device to the port marked as ASCII (EIA-232) or ASCII TCP/IP respectively of IntesisBox. Respect always the maximum distance of 15 meters for this cable. (See details for this bus cable in section Connections of this document).

4. Connect the bus cable coming from the EIB network to the port marked as KNX TP-1 (EIB) of IntesisBox. (See details for this communication cable in section Connections of this document).

5. Power up IntesisBox using a standard power supply 220/125VAC-12VDC/300mA for example.

**WARNING!** In order to avoid earth loops that can damage the gateway and/or any other equipment connected to it, we strongly recommend:

- The use of DC power supplies, floating or with the negative terminal connected to earth. **Never use a DC power supply with the positive terminal connected to earth.**
- The use AC power supplies only if they are floating and not powering any other device.

6. Connect the communication cable coming from the serial port of your laptop PC to the port marked as PC Console of IntesisBox. If you prefer using the Ethernet connection, connect the PC to the **Pc Console** port of the IntesisBox. (See details for this communication cable in section Connections of this document).
7. Open LinkBoxEIB, create a new project selecting a copy of the one named **DEMO ASCII** and give it the name desired, select the serial port used to connect to the gateway (menu Configuration -> Connection) and switch working mode to **on-line** (checkbox off-line/on-line). The IntesisBox identification must appear in the IntesisBox communication console window as showed below.

![IntesisBox Communication Console](image)

8. Open the **ASCII Communication Viewer** window (menu View -> Bus -> ASCII), force some point's polling from the ASCII device connected to IntesisBox, and check that there is communication activity, some TX frames and some other RX frames. This means that the communication with the ASCII device is ok. In case there is no communication activity between IntesisBox and the ASCII device check that ASCII device is operative and well connected to the IntesisBox.

![ASCII Communication Viewer](image)

9. Open the **KNX Protocol Communication Viewer** window (menu View -> Bus -> EIB) and check that there is communication activity, some TX frames and some other RX frames as showed in the figure below. This means that the communication with the KNX system is ok.

![KNX Protocol Communication Viewer](image)
## Visor Comunicación EIB

| rx: 9c, l1, 2, 8, 5, e1, 0, 81, 1d,  
| rx: 9c, l1, 2, 8, 5, e1, 0, 81, 1d,  
| rx: 9c, l1, 2, 8, 5, e1, 0, 81, 1d,  
| TX: bc, ff, fa, 8, 3, e1, 0, 80, 2c,  
| rx: 8b,  
| rx: bc, l1, 2, 8, 5, e1, 0, 80, 3c,  
| rx: 9c, l1, 2, 8, 5, e1, 0, 80, 1c,  
| rx: 9c, l1, 2, 8, 5, e1, 0, 80, 1c,  
| TX: bc, ff, fa, 8, 3, e1, 0, 81, 2d,  
| rx: 8b,  
| rx: bc, l1, 2, 8, 5, e1, 0, 81, 3a,  
| rx: 9c, l1, 2, 8, 5, e1, 0, 81, 1d,  
| rx: 9c, l1, 2, 8, 5, e1, 0, 81, 1d,  
| TX: bc, ff, fa, 8, 3, e1, 0, 80, 2c,  
| rx: 8b,  
| rx: bc, l1, 2, 8, 5, e1, 0, 80, 3c,  
| rx: 9c, l1, 2, 8, 5, e1, 0, 80, 1c,  
| rx: 9c, l1, 2, 8, 5, e1, 0, 80, 1c,  
| rx: 9c, l1, 2, 8, 5, e1, 0, 80, 1c,  
| tx: 8b, l1, 2, 8, 5, e1, 0, 80, 1c,  
| rx: 8b, |
7. Connections

Power
See technical characteristics

ASCII TCP/IP

KNX TP-1
(Bus EIB)

IntesisBox®
www.intesis.com

EIA-232

PC Console

Ethernet

LinkBoxEIB
Only for configuration

ASCII
EIA-232

EIA-232/Ethernet

CMN 24Vac
9 - 30Vac
Min. 100 VA
Max. 125 VA
50-60Hz
Max. 127mA
Max. 125mA

Connections

LinkBox

EIB

Only for configuration

Power

See technical characteristics
8. Mechanical & electrical characteristics

<table>
<thead>
<tr>
<th>Characteristics</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enclosure</td>
<td>Plastic, type PC (UL 94 V-0). Dimensions: 107mm x 105mm x 58mm.</td>
</tr>
<tr>
<td>Colour</td>
<td>Light Grey. RAL 7035.</td>
</tr>
<tr>
<td>Power</td>
<td>9 to 30Vdc +/-10% 1.4W. 24Vac +/-10% 1.4VA. Plug-in terminal block for power connection (2 poles).</td>
</tr>
<tr>
<td>Mounting</td>
<td>Surface. Wall. DIN rail EN60715 TH35.</td>
</tr>
<tr>
<td>KNX port</td>
<td>1 x KNX TP1 (EIB) (2 poles plug-in terminal block).</td>
</tr>
<tr>
<td>ASCII port</td>
<td>1 x EIA232. (DB9 male connector DTE).</td>
</tr>
<tr>
<td>LED indicators</td>
<td>1 x Power. 2 x ASCII port activity (Tx, Rx). 2 x KNX port activity (Tx, Rx).</td>
</tr>
<tr>
<td>Console port</td>
<td>EIA232. DB9 female connector (DCE).</td>
</tr>
<tr>
<td>Configuration</td>
<td>Via EIA-232 serial port or Ethernet TCP/IP port</td>
</tr>
<tr>
<td>Firmware</td>
<td>Allows upgrades via console port.</td>
</tr>
<tr>
<td>Operational temperature</td>
<td>-40°C to +70°C</td>
</tr>
<tr>
<td>Operational humidity</td>
<td>5% to 95%, non condensing</td>
</tr>
<tr>
<td>Protection</td>
<td>IP20 (IEC60529).</td>
</tr>
<tr>
<td>Certification</td>
<td>CE</td>
</tr>
<tr>
<td>RoHS conformity</td>
<td>Compliant with RoHS directive (2002/95/CE).</td>
</tr>
</tbody>
</table>
9. Dimensions

Free space recommended to install the device into a cabinet (wall or DIN rail mounting), with space enough for external connections: